Mysql数据库安装冲突:Package(s) mysql-libs available, but not installed.和file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server解决办法 – 21运维
通知: .-...

Mysql数据库安装冲突:Package(s) mysql-libs available, but not installed.和file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server解决办法

mysql 21运维 6343浏览 0评论

今天需要安装一个包:yum install  perl-DBD-MySQL.*  -y
结果一大堆错误:

.
.
.
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server-5.5.16-1.rhel4.x86_64

按照之前思路就是想到卸载以后重新安装这些依赖包:

yum remove mysql-libs
结果又提示:
Package(s) mysql-libs available, but not installed.

于是查了很多资料终于解决了。
目前说下解决办法:基本意思是之前安装了mysql-libs-5.1.73-7.el6.x86_64 ,和将要操作的MySQL-server-5.5.16-1.rhel4.x86_64有冲突,需要进行一个兼容性处理。网上下载了MySQL-shared-compat-5.5.16-1.rhel4.x86_64.rpm包安装再去yum搞定,完美解决。

rpm包下载地址:http://downloads.mysql.com/archives/community/ 根据自己的把版本选择对应rpm包安装即可。我这里选择的是MySQL-shared-compat-5.5.16-1.rhel4.x86_64.rpm。

转载请注明:21运维 » Mysql数据库安装冲突:Package(s) mysql-libs available, but not installed.和file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.73-7.el6.x86_64 conflicts with file from package MySQL-server解决办法

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址