error: Failed dependencies: perl(DBD::mysql) is needed by percona-xtrabackup-以及perl(Time::HiRes) is needed by percona-xtrabackup-xxx报错解决办法 – 21运维
通知: .-...

error: Failed dependencies: perl(DBD::mysql) is needed by percona-xtrabackup-以及perl(Time::HiRes) is needed by percona-xtrabackup-xxx报错解决办法

linux 21运维 3249浏览 0评论

之前也遇到过类似报错,不过网站都没记录,这次记录下。实际网页上的资料也都是有很多的正确解决方案。
问题如下,通过官网下载的XtraBackup rpm包,安装XtraBackup 这个mysql备份工具报错如下:

[[email protected] src]# rpm  -ivh   percona-xtrabackup-22-2.2.13-1.el6.x86_64.rpm 
warning: percona-xtrabackup-22-2.2.13-1.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
error: Failed dependencies:
	perl(DBD::mysql) is needed by percona-xtrabackup-22-2.2.13-1.el6.x86_64
	perl(Time::HiRes) is needed by percona-xtrabackup-22-2.2.13-1.el6.x86_64
[[email protected] src]#  yum -y install perl perl-devel libaio libaio-devel perl-Time-HiRes perl-DBD-MySQL

解决办法如下:

 yum -y install perl perl-devel libaio libaio-devel perl-Time-HiRes perl-DBD-MySQL

再次重新安装,问题解决。

转载请注明:21运维 » error: Failed dependencies: perl(DBD::mysql) is needed by percona-xtrabackup-以及perl(Time::HiRes) is needed by percona-xtrabackup-xxx报错解决办法

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址