Linux(centos) 环境下如何源码编译安装git – 21运维
通知: .-...

Linux(centos) 环境下如何源码编译安装git

Git 21运维 2200浏览 0评论

21运维原创,转载请注明出处。

最近线上要使用git进行代码发布和版本管理了,之前搞过,一直没有做记录。从今儿起开始记录这块。

linux上(当前文章使用的是centos,ubuntu采用apt-get这里不细说)安装git有两个办法:yum安装和source编译,不建议yum。 yum都是老版本的,建议去github上下载源码编译安装。这里记录下步骤:
1,安装依赖包。

源码编译之前,先安装一些依赖:

yum install  autoconf automake libtool perl cpio curl curl-devel  zlib-devel openssl-develexpat-devel  gettex-devel -y

2,下载并编译安装。
源码下载地址:https://github.com/git/git/releases
这里我们以当前最新版本https://github.com/git/git/archive/v2.11.0-rc1.tar.gz 为例操作。

wget https://github.com/git/git/archive/v2.11.0-rc1.tar.gz
tar zxvf  v2.11.0-rc1.tar.gz
cd git-2.11.0-rc1/
make configure  #注意这一步,默认无法直接进行./configure,不存在configure文件,需要执行这一步。
./configure   --prefix=/usr/local/git
make
make install

安装完毕。

3,设置环境变量。

编译安装完以后git命令无法直接使用,需要设置下环境变量。执行如下操作:

echo "export PATH=/usr/local/git/bin:$PATH" >> /etc/profile
source  /etc/profile

好了,现在就可以直接使用了。查看效果:

[[email protected] git-2.11.0-rc1]# git --version
git version 2.11.0-rc0

注意:make的时候可能有报错:

[[email protected] git-2.11.0-rc1]# make
    SUBDIR perl
/usr/bin/perl Makefile.PL PREFIX='/usr/local/git' INSTALL_BASE='' --localedir='/usr/local/git/share/locale'
Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Makefile.PL line 3.
BEGIN failed--compilation aborted at Makefile.PL line 3.
make[1]: *** [perl.mak] Error 2
make: *** [perl/perl.mak] Error 2

处理办法:
yum install perl-ExtUtils-Embed -y 安装完以后重新编译即可。

转载请注明:21运维 » Linux(centos) 环境下如何源码编译安装git

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (1)

  1. 如果make的时候报错:/bin/sh: msgfmt: command not found 处理办法如下: yum install gettext-devel -y
    21运维2016-11-28 17:01 回复