安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法 – 21运维
通知: .-运维QQ交流群:534829726 欢迎加入。

安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

linux 21运维 1558浏览 0评论

由于本站服务器进行了调整,所有的运行环境都进行了重装,打算把zabbix安装起来,以便服务器啥情况都有通知可以收到。于是到官网下载当前最新版本zabbix 3.4来安装,还是和之前的依赖略有不同,譬如:
版本编译报错configure: error: Unable to use libevent (libevent check failed)
解决办法如下:

yum install libevent-devel  -y

问题解决。

 

说明:当前我用的编译参数如下

./configure --prefix=/usr/local/zabbix/ --enable-server  --with-mysql --with-net-snmp --with-libcurl --with-libxml2 --with-unixodbc

如服务器是新服务器,一般依赖不足。建议一起安装如下依赖,减少因为缺少依赖报错的可能性:

yum install unixODBC-devel mysql-devel net-snmp-devel libxml2-devel libcurl-devel libevent-devel

转载请注明:21运维 » 安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址